SolarEdge in Latest Beta / Port Number

Compatibility (hardware, devices and OS)
pvm
Posts: 857
Joined: Tuesday 17 June 2014 22:14
Target OS: NAS (Synology & others)
Domoticz version: Stable
Location: NL
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by pvm » Saturday 20 June 2015 16:00

Same here, i had to ask installer. One thing is the script results in grapjes schorsing energ usage instead of amount delivered. Pure textuur issue, values are correct
Synology NAS, PI3, ZWave, Xiamo zigbee devices, BTLE plant sensor

rharmsen
Posts: 6
Joined: Sunday 31 May 2015 18:39
Target OS: -
Domoticz version:
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by rharmsen » Sunday 21 June 2015 19:56

Yobby wrote:
Pietertje wrote:Hi Yobby,
Can you explain more how to implement in Domoticz because this is a better way as through PVoutput
First you need a virtual device to gather the data. If it was working before and you already have a device with SolarEdge data, you may be able to use that instead.
  • goto Setup > Hardware
  • Add hardware of Type Dummy
  • When added, click Create Virtual Sensors
  • Sensor type: Electric (Instant+Counter)
  • goto Setup > Devices
  • click on the green button with an arrow of the newly created virtual device and give it a name.
  • take note of the Idx of that device, as it is used in the lua-script I pasted above.
Then put the lua-script above in a file named script_time_SolarEdge.lua in the directory domoticz/scripts/lua/
Replace key/id values with your own, and it should work.
Normally we get every 5 minutes the data from the hadware
In the api-documentation, it says 15 minute interval. I have it set to 10 minutes, but half the time there's no new data yet.
Keep in mind that the api has a limitation of 200 api-calls per day. If you have other services using the same data (eg. PVoutput), those are counted as well.
Would be nice if getting data from SolarEdge directly could be implemented in the Domoticz code, instead of using scripts.

Zwollenaar
Posts: 17
Joined: Monday 10 August 2015 21:27
Target OS: Raspberry Pi
Domoticz version: v2.4031
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Zwollenaar » Monday 10 August 2015 21:40

I'fe read alot about domoticz and wanted to ask something.

I run domoticz on an RPi2 version v2.2692
Today i was working to get the solar panels from solaredge working (one step at a time ;))

I have an Se4000 with WiFi option.

I changed prod.solaredge.com in to 192.168.1.11 the Port remained 22222

On the Raspberry i added solaredge and added prod.solaredge.com port 22222

But you guessed it, it doesn't work. The solaredge doesnt show S_ok and indeed no logging to the site.
The raspberry doesnt show any kind of response to the solar panels. (Still active during day)
I resetted RPi2 and the solaredge, but with no results.

I read some had simular problems, but did they sorted it?

Jantje1972
Posts: 16
Joined: Monday 02 February 2015 22:25
Target OS: Raspberry Pi
Domoticz version: 2.2336
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Jantje1972 » Tuesday 11 August 2015 16:57

For me it is still not sorted, there are no device's in domoticz for my solaredge.

Zwollenaar
Posts: 17
Joined: Monday 10 August 2015 21:27
Target OS: Raspberry Pi
Domoticz version: v2.4031
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Zwollenaar » Wednesday 12 August 2015 20:16

Does anyone have the Solaredge Tool V2 for me?

The latest from Solaredge is version 3, and @ preferences, it has an password option? (Resulting only in monitoring mode) i cannot alter the server adress.
It might be accessible without password in Version 2 (cause the manual 2.0 on solaredge does'nt refer to a password.)

I will try tonight with LAN cable if that works.
Am also curious how you know it sees the Raspberry? or that the Raspberry do get a message from the solaredge.
Now am not sure where the problem is, the SE not reaching the RPi, or the RPi not able to handle the message? (think its the first option though)

EDIT 1:
interresting.
When i hooked up a LAN cable, and set server to LAN it worked. and on the solaredge "S_OK" showed.
And in devices i saw 5 devices

Removing the LAN, and putting it back to WiFi, resulted in a loss of communication.

In LAN mode, you see a status window passing by resulting in all '1's and ending up with S_OK.
This screen doesn't show when Server Wifi is selected (so harder to decode the problem)

So for now my (and your) solution would/could be, getting an LAN-230--230-LAN kit to get a LAN connection upstairs..

But i do know my settings in the solaredge and Raspberry were right.

EDIT 2
I installed a Lan solution (range extender with LAN port) so the Soleredge can use the LAN connection.

I changed the server to LAN , and S_OK showed.

But overnight the solaredge changes the server back into WiFi. So communication is lost again. And S_OK is gone. (Even with loading default WiFi settings (to get rid of ssid and wifi key))

The only solution fow now was removing the WiFi unit, and now it keeps sending the data to the raspberry and the solaredge site
Last edited by Zwollenaar on Wednesday 16 September 2015 21:26, edited 1 time in total.

Zwollenaar
Posts: 17
Joined: Monday 10 August 2015 21:27
Target OS: Raspberry Pi
Domoticz version: v2.4031
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Zwollenaar » Wednesday 16 September 2015 21:16

I reported the problem to Solaredge.

Solaredge mentioned that i was the only one with this problem.
I told them it's bigger than just my installation, and mentioned this forum/thread.

So my suggestion to the forum users would be, report the problem at Solaredge http://www.solaredge.com/groups/service/support So solaredge can have some more information regarding the problem.

ubfssF
Posts: 43
Joined: Monday 02 November 2015 15:12
Target OS: Linux
Domoticz version: 2.2364
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by ubfssF » Monday 02 November 2015 16:00

First time user of Domoticz (on a Synology). Do I have to use the brackets for the API in the Lua script, or not?

With brackets, with a fake API:
vSeApiKey = 'GHJJYUFTF56FDRFHJJH4HD7F2GFT' -- api-key from SolarEdge

Without brackets:
vSeApiKey = GHJJYUFTF56FDRFHJJH4HD7F2GFT -- api-key from SolarEdge

I tried both, but both don't work :(

EDIT, 2nd problem/question:
The URL is working without brackets; I can get a XML-file from https://monitoringapi.solaredge.com in a telnet session as root.
With the curl command I can create seapi.txt with the URL, like the script does. Output:
{"overview":{"lastUpdateTime":"2015-11-02 15:53:50","lifeTimeData":{"energy":36010.0},"lastYearData":{"energy":35067.156},"lastMonthData":{"energy":11459.68},"lastDayData":{"energy":5926.917},"currentPower":
{"power":97.5},"measuredBy":"INVERTER"}}

I don't see a seapi.txt file created in the lua directory, so somehow the script doesn't start collecting data. Could it be that a wrong setting prevents it from starting? The virtual device I've created has the Idx of 1, as it is the first device in the setup.

Yobby
Posts: 15
Joined: Thursday 10 April 2014 9:18
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Yobby » Tuesday 03 November 2015 9:58

In the script you have to use it like this:
ubfssF wrote: With brackets, with a fake API:
vSeApiKey = 'GHJJYUFTF56FDRFHJJH4HD7F2GFT' -- api-key from SolarEdge
{"overview":{"lastUpdateTime":"2015-11-02 15:53:50","lifeTimeData":{"energy":36010.0},"lastYearData":{"energy":35067.156},"lastMonthData":{"energy":11459.68},"lastDayData":{"energy":5926.917},"currentPower":
{"power":97.5},"measuredBy":"INVERTER"}}
That's the information we're after. The fact that seapi.txt isn't created is the root of the problem. What does it say in the log (In Domoticz: Setup/Log) when the script is run?

ubfssF
Posts: 43
Joined: Monday 02 November 2015 15:12
Target OS: Linux
Domoticz version: 2.2364
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by ubfssF » Wednesday 04 November 2015 22:13

It does more than it did, I can see in the logging, as the error was: 2015-11-04 20:40:00.288 Error: EventSystem: ...local/domoticz/var/scripts/lua/script_time_SolarEdge.lua:13: attempt to concatenate global 'vSeApiKey' (a nil value)

Now the error is:
2015-11-04 21:00:00.311 Error: EventSystem: ...local/domoticz/var/scripts/lua/script_time_SolarEdge.lua:16: cannot open file './scripts/lua/seapi.txt' (No such file or directory)

I've created seapi.txt with touch and changed rights to writable for all, but that didn't work. Also setting the lua directory as writable for all doesn't fix it. I guess that domoticz cannot find the directory lua, but I don't know what working directory it starts in. The script is located in /usr/local/domoticz/var/scripts/lua/script_time_SolarEdge.lua

ubfssF
Posts: 43
Joined: Monday 02 November 2015 15:12
Target OS: Linux
Domoticz version: 2.2364
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by ubfssF » Thursday 05 November 2015 8:29

Changed the path to a /tmp directory and now the log shows: 2015-11-05 07:25:01.096 EventSystem: Script event triggered: /usr/local/domoticz/var/scripts/lua/script_time_SolarEdge.lua

It is dark outside, so I'll wait until the sun starts to shine :)

ubfssF
Posts: 43
Joined: Monday 02 November 2015 15:12
Target OS: Linux
Domoticz version: 2.2364
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by ubfssF » Thursday 05 November 2015 11:03

It works: problem with lies probably in the Synology package which is kindly provided by jumbotroll. 8-) 8-)

Values are changing per 5 minutes, so the 10 minutes which are used in the script on the previus page of this thread can be changed.

User avatar
jannl
Posts: 797
Joined: Thursday 02 October 2014 6:36
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Geleen
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by jannl » Friday 06 November 2015 12:44

Can it be solardege is no longer updating since the lastes stable?
Forwarding to the solaredge portal seems to be ok.

antwan
Posts: 282
Joined: Saturday 13 July 2013 13:28
Target OS: Linux
Domoticz version: Latest
Location: Hilversum, The Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by antwan » Friday 06 November 2015 19:26

No problems here.
Cubietruck: Aeotec Z-Wave+, RFXtrx433E, RFXtrx868, P1 Converter, TE923 display, Voltcraft CO-20, SolarEdge proxy
Rasp Pi 2B: Aeotec Z-Wave, 3x DS18S20 (1-wire), BMP085 (i2c)

User avatar
EddyG
Posts: 106
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by EddyG » Saturday 07 November 2015 14:46

Is there any progress made on the error?

2015-11-07 13:34:46.601 Error: SolarEdge: Unknown Type: 1408
2015-11-07 13:34:46.602 Error: SolarEdge: Something not handled correctly, having extra bytes!
Regards,
Eddy

DomoArie
Posts: 7
Joined: Tuesday 10 November 2015 20:36
Target OS: Raspberry Pi
Domoticz version: 3.5877
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by DomoArie » Tuesday 10 November 2015 21:01

Hi
Could I open the discussion here and ask how you were able using the SolarEdge Config tool to enter the inverter? I have versie 3 of the tool and connect my laptop to the USB connector on the mainboard in the inverter.
I can see (monitoring view) all sort of things, but I am not able to change the forwarding address. In fact I have the same problem as @Zwollenaar is experiencing.
If one of you still have that version two of the config tool (were one could connect in change modus), I would like to receive that version two and change my settings. Anyone? Or does someone has the famous password that SolarEdge will not disclose?
The other way could be using the API SolarEdge provides.
I understood that a few members did rather a lot of action on this SolarEdge thing.

Crusader2003
Posts: 1
Joined: Friday 20 November 2015 11:34
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Crusader2003 » Friday 20 November 2015 12:44

Thank you Antwan,

Your script works fine.
solar.JPG
screenshot
solar.JPG (20.01 KiB) Viewed 2485 times
antwan wrote:Change in your inverter the url from:
prod.solaredge.com
to the ip addres of your domoticz server.

In Domoticz put at remote address:
Remote Address: prod.solaredge.com
Port: 22222

For me this is a intermediate solution. In the end I want to connect to the rs232 or usb port on the inverter and leave the ip part on the inverter like it was.
The advantage of this is that the data is coming in every 0,5 sec (the same intervall as on the display).

We still have to integrate the optimisers in Domoticz.

prein
Posts: 10
Joined: Thursday 26 November 2015 12:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by prein » Thursday 26 November 2015 12:29

Yobby wrote: Working LUA script
Above LUA script works perfect, except for one thing: it checks every 15 minutes for an update, at .00, .15, .30 and .45.
new information on the website is available shortly after, so let's say at .01, .16, .31 and .46. Information from the Solaredge is thus delayed by minimal 15 minutes.

is it possible that the LUA script triggers at a different time? for example at .05, .10, .35 and .50?
I think that is a better implementation than to poll the website every 5 minutes.

Edit: Well that was easy! I just replaced:

Code: Select all

if os.date("%M") % vInterval == 0 then
with

Code: Select all

if (os.date("%M")-5) % vInterval == 0 then

Zwollenaar
Posts: 17
Joined: Monday 10 August 2015 21:27
Target OS: Raspberry Pi
Domoticz version: v2.4031
Location: Netherlands
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by Zwollenaar » Tuesday 01 December 2015 13:52

i get in de log from domoticz:

Error: SolarEdge: Unknown Type: 0061
SolarEdge Something not handled correctly, having extra bytes!

Anyone got a clue what error 0061 might be

Am running Domoticz Stable; 3530

User avatar
jannl
Posts: 797
Joined: Thursday 02 October 2014 6:36
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Geleen
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by jannl » Tuesday 01 December 2015 13:58

I get the same error message, but it looks like it works oke.

action3
Posts: 1
Joined: Tuesday 01 December 2015 22:20
Target OS: Linux
Domoticz version:
Contact:

Re: SolarEdge in Latest Beta / Port Number

Post by action3 » Wednesday 02 December 2015 21:00

hi

i am a newby in domoticz.
and i have read this post.

i have a solaredge se200 and Domoticz on my linux mint 17

i get the error Error: EventSystem: //domoticz/scripts/lua/script_time_SolerEdge.lua:3: unexpected symbol near '+'
i have a API key from Solaredge

i hope someone knows how to fix it

thx

gr

edit
stupid it was a typo :(

but now the error is
Error: EventSystem: /home/tv/domoticz/scripts/lua/script_time_SolerEdge.lua:22: attempt to concatenate global 'vSolarPower' (a nil value)

pff i hope to hear

thx any way

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests