Usage last 24 hour (EM6600)

Post Reply
salvation
Posts: 45
Joined: Saturday 06 September 2014 15:34
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Usage last 24 hour (EM6600)

Post by salvation » Wednesday 12 November 2014 21:10

I'm using Domoticz V2.2102 on a RPi. I've attached an RFXCOM and a Aeotec Z2. For power metering I use a Eminent EM6600. This device is correctly recognized by Domoticz as a NorthQ NQ-92021 Power Reader which is technically the same according to a dutch domotica webshop.

But I experience some differences in behaviour. The hourly power usage (Usage last 24 hour) is shown in the graph when I check the log of the device via: Setup -> Devices -> electraMeter (log icon on the right).
Image

But when I check this graph (after adding it) on the Utility Tab, this graph show only zero.
Image

Somebody know how this can be solved? Is it a bug or a misunderstanding by me, this should be the same graph?

salvation
Posts: 45
Joined: Saturday 06 September 2014 15:34
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: Usage last 24 hour (EM6600)

Post by salvation » Tuesday 18 November 2014 23:25

Anybody an idea?

Immo
Posts: 57
Joined: Wednesday 11 February 2015 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by Immo » Wednesday 11 February 2015 12:06

Hi

Reviving your thread :)
I installed my EM6600 yesterday connected to Domoticz on Pi + Razberry.
Got it recognized, it's in the mesh. I can see it, I can enter settings.
however it's not showing any data, except for the baseline I entered (in my case 66000 kWh).

Do I need to make certain settings in order to get the data FROM the EM6600 TO Domoticz?
Can you post a screenshot of your settings?

Cheers

memyself
Posts: 32
Joined: Wednesday 04 February 2015 20:57
Target OS: Raspberry Pi
Domoticz version: 2.2284
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by memyself » Thursday 12 February 2015 21:23

Immo wrote:Hi

Reviving your thread :)
I installed my EM6600 yesterday connected to Domoticz on Pi + Razberry.
Got it recognized, it's in the mesh. I can see it, I can enter settings.
however it's not showing any data, except for the baseline I entered (in my case 66000 kWh).

Do I need to make certain settings in order to get the data FROM the EM6600 TO Domoticz?
Can you post a screenshot of your settings?

Cheers
Hello Immo,

I do have the same issue. The device will send data if you wake it up manually (pushing the button once) but after that it remains silent. It falls asleep never to wake up. At least not in 24 hours.

Settings :

Image

Mesh overview :

Image

Domoticz version : 2.2168
Controller : Aeon Z-Wave stick

I know some people here have got theirs to work, but they might have the original NorthQ while I have a rebranded Eminent EM6600. Last message was Node010 is asleep. And it never wakes up.....

memyself
Posts: 32
Joined: Wednesday 04 February 2015 20:57
Target OS: Raspberry Pi
Domoticz version: 2.2284
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by memyself » Thursday 12 February 2015 21:48

One more thing, if you read the FAQ on the NorthQ site, you will see this :

Image

Mine does not blink.... :roll: And before you ask, batteries are correct inserted. If I push the button, it sends data.

Immo
Posts: 57
Joined: Wednesday 11 February 2015 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by Immo » Friday 13 February 2015 12:13

Hi

Here's what I found out until now.
1st of all, if you don't configure it to pulse meter, it will not read the pulses. might seem trivial, but somehow it didn't update the reader after resetting it, so double-check that :)
If I press the button I CAN see the led blinking.
It's not possible to set the pulse count to 100.000 (I have a 10.000 imp/kwh and a 1.000 imp/kwh led, wanted to use the 2nd one). I tried eiditing the xml, but not luck so it might be a limit in the em6600.

Yesterday I managed to fiddle around with some settings and everytime I opened the dashboard it would actively request data from the em6600.
Now I have the same situation as yours but it does generate the hourly graphs in devices -> report
Now the thing is.. I have no idea what triggered it to do this..

Yesterday it worked but as the graphs were messed up with my manual input I made screenshot of the settings, remove the node, re-included it and did the exact same settings.. not working..
messed around with some polling and also switched on polling for another device, not it's working again.
The problem now however is it's draining the batteries like crazy.. 3 days, 50% left..

I found this topic
http://www.domoticz.com/forum/viewtopic.php?f=6&t=4226
There I see actual data being sent to domoticz FROM the reader, my log doesn't show these.

these are my settings
em.JPG
settings
em.JPG (95.67 KiB) Viewed 4588 times
running 2.2025 btw.. I'll check to update tonight to a newer (beta) version

memyself
Posts: 32
Joined: Wednesday 04 February 2015 20:57
Target OS: Raspberry Pi
Domoticz version: 2.2284
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by memyself » Saturday 14 February 2015 14:35

Why is your realtime mode set to 0? Mine had a huge value of 18.000.

My Energy Meter is now connected to the server for some days. No data whatsoever. This is the log:

Image

If you push the button once, nothing happens. If you push it three times, this happens :

Image

THere even is a meter report in it. Domoticz immediately updates te value.

So, I can now conclude some things:
- the meter actually measures the led, and it had recorded 9,4kWh since 12-2
- the batteries (replaced) are full
- the distance between the sensor and the controller is ok as it sends data
- if needed, there is a Fibaro binary switch in the same closet, so it can use the mesh
- it won't sent data on it's own, like it should
- Domoticz knows when a device is awake or asleep, the meter is shown as "awake" while asleep for days now

Immo
Posts: 57
Joined: Wednesday 11 February 2015 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by Immo » Monday 02 March 2015 12:41

sorry for the late response, I was on holiday :)
the realtime value is (as far as I know) the amount of ticks stored internally so will differ for everyone..'
I made the settings as shown in the pictures, pressed the button on the meter and it started sending data every 15 minutes, which it's still doing.

Also updated to the latest build of Domoticz which is now showing the last 24 hour usage graph from the dashboard (and not only from the devices) now

how do you get the logging you posted? perhaps I can check mine and post a part to see the differences

Immo
Posts: 57
Joined: Wednesday 11 February 2015 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by Immo » Thursday 05 March 2015 17:47

Update, I had to soft reset my controller so it lost connection.
The trick to get it to work again is have the settings as shown.. I did notice it can take quite some time for the settings actually being stored in the em6600 (pushing the button to wake it up seemed to help a bit).
After that I just pushed the button and it started syncing again.. the stored 'ticks' were logged in Domoticz in 1 hour instead of spread across the hours that passed, but the daily amount is correct..
With the new update on Domoticz it also shows the last 24 hours (or 48 in my case) correct

Immo
Posts: 57
Joined: Wednesday 11 February 2015 12:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by Immo » Monday 09 March 2015 1:32

Well, I think I figured it out..
I moved to a Pi2 and the em6600 wasn't showing new data. Strangely all hardware was ok, except this.
The pulses per kWh and meter type were reset..

Anyway..
To get it to work turn on polling for the em6600, set a proper polling interval in the controller, mine is as 10.
Than set option 10 of the em6600 to 5 (or higher if needed)"
What happens is the em6600 will wake up and stay awake for 5 led pulses, within that time the controller polled the data and there you go..
To get it working the first time press the button on the em6600 once. If it doesnt worh three times.
From than on it should wake every 15 minutes and the controller will pull data.
Should you have a very high power usage or long polling interval you might have to play with the values.

dewagt
Posts: 10
Joined: Thursday 19 February 2015 11:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Usage last 24 hour (EM6600)

Post by dewagt » Friday 14 August 2015 10:32

A question about the Eminent EM6600... It's delivered with a Zwave stick. Is this stick also usable for other Zwave products? If so it's a cheap way to have an energy reader and an zwave stick :-)
1x RPi B+
1x RFXcom433e
KAKU: 1x APA3-1500R (3 switches), 4x AMST-606, 1x ASUN-650, 1x AFR-060, 1x AFR-100
ELRO: 4x AB400
ELRO: 4x COCO GDR2-1000R
Wether: 3x Xiron outdoormeters, Alecto 4500, Alecto 1700
Doorbells: 2x action
LG-tv, Yamaha-receiver

User avatar
mrf68
Posts: 276
Joined: Monday 23 February 2015 13:45
Target OS: Windows
Domoticz version: 3.4834
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by mrf68 » Wednesday 18 November 2015 13:21

I know this topic is a bit old, but I received my EM6600 last week. It was very cheap at staples.nl.

http://www.staples.nl/smart-energy-read ... er=2660539

Because I got it working with the origi al software but not in Domoticz, I searched for EM6600 and found this topic. I've got it working now. And to answer the question by dewagt: I also have some EM6550 wall plugs from Eminent and they work with the stick that came with the energie reader. I can't tell if it works with other brands.

User avatar
Mediacj
Posts: 102
Joined: Wednesday 11 February 2015 17:09
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by Mediacj » Saturday 21 November 2015 2:16

Nice so you have Eminent wall plugs and the enery reader working in Domoticz with only the included usb zwave stick?

User avatar
mrf68
Posts: 276
Joined: Monday 23 February 2015 13:45
Target OS: Windows
Domoticz version: 3.4834
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by mrf68 » Tuesday 24 November 2015 11:26

@Mediacj: yes I have.

Image

JeroenL
Posts: 21
Joined: Sunday 27 December 2015 20:38
Target OS: Raspberry Pi
Domoticz version: 3.5837
Location: Netherlands
Contact:

Re: Usage last 24 hour (EM6600)

Post by JeroenL » Saturday 05 November 2016 13:03

I am also using the out-of-the-box Zwave controller from Eminent. (Sigma Designs). After fiddling around a long time, I managed to add a Fibaro Wall plug to it.
I did not manage to get this done in Domoticz, but I used the Eminent Windows software. There is an advanced "set-up" button which brings you a very basic web-interface. Here I managed to add a new device to the Zwave network. I then plugged the USB stick back in Domoticz (restart twice!) and the devices are recognised.

I also have a Aetec Gen5 stick, this works with the Fibaro Wall plug & Domoticz, but it does not work together with the PowerReader. So I decided to stick my Sigma Designs controller. The Aetec USB stick is in a drawer :-)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest