wunderground API usage alert

Post Reply
Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

wunderground API usage alert

Post by Ajderev » Thursday 27 July 2017 17:36

Hello All

I started using the Domoticz in two days with my Evohome.
To see outside temp I added wunderground API.

I got two emails saying: Your wunderground API key (xxxxxxxxxx) exceeded its allotted usage today by making 502 calls in a day but the limit is 500.

Is there something I can do so I do not get the API disabled?
My Settings are show below:
1.JPG
1.JPG (98.92 KiB) Viewed 2720 times
2.JPG
2.JPG (127.56 KiB) Viewed 2720 times
I do not know how are the API calls made?
Is one API call for all sensor of the weather station or each sensor gets API call?

I will really appreciate some quick answer because I have only 1 Rain drop left.

Thaks in advance to anybody which spend a time to help me.

Best Regards
Stefan Ajderev

pvm
Posts: 930
Joined: Tuesday 17 June 2014 22:14
Target OS: NAS (Synology & others)
Domoticz version: Stable
Location: NL
Contact:

Re: wunderground API usage alert

Post by pvm » Thursday 27 July 2017 17:44

You don't have additional dashboards in addition to the standard domoticz one right?
Synology NAS, PI3, ZWave, Xiamo zigbee devices, BTLE plant sensor

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Thursday 27 July 2017 21:39

No, I didn't add anything to the standard installation.
I'm running on Windows 10 PC

DennisD
Posts: 66
Joined: Friday 18 September 2015 21:46
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by DennisD » Thursday 27 July 2017 21:54

I have had the same emails, apparently Domoticz was making 503 calls instead of the maximum of 500. Nothing has changed and i'm running the latest beta's on an rpi 3

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Thursday 27 July 2017 22:47

So is this mean there is nothing I can do to limit the number of calls?
Should I disable wunderground API for the moment until it is fixed so it does not get disabled?

I'm an average user and Domoticz allowed me to do use it without any scripting nor Linux knowledge.
It is really great software I'm just discovering. I love how it works with my Evohome.

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Thursday 27 July 2017 23:03

I just noticed in the log

2017-07-27 21:52:51.538 Wunderground: Worker started...
2017-07-27 21:54:07.408 Wunderground: Worker started...
2017-07-27 21:55:23.217 Wunderground: Worker started...
2017-07-27 21:56:39.081 Wunderground: Worker started...
2017-07-27 21:57:54.914 Wunderground: Worker started...

It is running every minute, not every 5 as I thought

Also, I have
2017-07-27 21:59:13.797 EventSystem - Python: Failed dynamic library load, install the latest libpython3.x library that is available for your platform.
Can you advise me how should I fix it in windows installation, please?

I downloaded and installed Download Python 3.6.2 for windows but still getting the error.

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Friday 28 July 2017 19:08

Ok, So I guess I need to disable it, for now, itril some solution came to light.

Toulon7559
Posts: 441
Joined: Sunday 23 February 2014 18:56
Target OS: Raspberry Pi
Domoticz version: latest
Location: Hengelo(Ov)/NL
Contact:

Re: wunderground API usage alert

Post by Toulon7559 » Friday 28 July 2017 19:41

24hours = 24*60minutes = 1440minutes/500calls ~ 1 call/3minutes
And all calls count, which apply your API-key.
No other solution than significant reduction of calling rate.
Anyway it makes no sense to call faster than once per 5 or 10 minutes, because the meteo-data at the source (= WUnderground) is not refreshed more often.
Set1 = RPI-B+RFXCom433+S0PCM+Linksprite-shield for BMP180/DS18B20/RS485+DDS238ZN1
Set2 = RPI-3+RFLinkGTW+ESP8266s+PWS_WS7000
Common = 2*PVLogger+PWS_TFA_Nexus+KAKUs
=> Energy & Data Management based on Time and on PV&Consumption&Meteo

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Saturday 29 July 2017 10:35

Hello Toulon7559,

Now if you tell me how to make it do a call once every 10 minutes it will be priceless :)

tlpeter
Posts: 405
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: wunderground API usage alert

Post by tlpeter » Saturday 29 July 2017 11:04

Isn't your system rebooting all the time? It will call WU at a service restart. Maybe the service restarted more than 500 times in one day.

mivo
Posts: 119
Joined: Friday 21 April 2017 8:58
Target OS: Raspberry Pi
Domoticz version: beta
Location: Czechia
Contact:

Re: wunderground API usage alert

Post by mivo » Saturday 29 July 2017 12:03

Ajderev wrote:Hello Toulon7559,

Now if you tell me how to make it do a call once every 10 minutes it will be priceless :)
Hi,

there is 10 min interval in C++ code and it works as expected on my system (beta 3.8143):

Code: Select all

2017-07-29 11:37:38.274  (Weather Underground LKPR) Temp + Humidity + Baro (WeatherUG LKPR)
2017-07-29 11:37:38.410  (Weather Underground LKPR) Wind (WeatherUG LKPR vitr)
2017-07-29 11:37:38.544  (Weather Underground LKPR) Rain (WeatherUG LKPR dest)
2017-07-29 11:47:38.592  (Weather Underground LKPR) Temp + Humidity + Baro (WeatherUG LKPR)
2017-07-29 11:47:38.727  (Weather Underground LKPR) Wind (WeatherUG LKPR vitr)
2017-07-29 11:47:38.862  (Weather Underground LKPR) Rain (WeatherUG LKPR dest)
It is question, why your Wunderground worker is restarting. Do you set something in "Data timeout" parameter ? It should be set to: disabled
My toys:
Raspberry Pi 3 + UPS PIco HV3.0 A Stack
Minibian (Raspbian Jessie) + Domoticz beta
RFLink 433 Gateway, 1wire DS18B20 temp sensors (GPIO)
RaZberry module + 2x Comet Z-Wave + Z-wave socket
---
Plugins: WeMo Switch, UPS PIco HV3.0A on GitHub

benbammens
Posts: 30
Joined: Tuesday 30 May 2017 19:43
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by benbammens » Saturday 29 July 2017 12:39

I have the same problem. It only happens when I have the dashboard open the whole day on my tablet.

Toulon7559
Posts: 441
Joined: Sunday 23 February 2014 18:56
Target OS: Raspberry Pi
Domoticz version: latest
Location: Hengelo(Ov)/NL
Contact:

Re: wunderground API usage alert

Post by Toulon7559 » Saturday 29 July 2017 18:22

@Ajderev

:-( Unfortunately not able to help you reducing the call-rate in Evohome, because no knowledge & no experience with that system.

My information on the number of calls is by experience.
At a certain time I had 2 lua-scripts uploading happily at 5 minute-rate to related WU-accounts and at the same time Domoticz making calls to get information from those 2 WUnderground-APIs: then you get quite soon an Alert from WUnderground .........
No (known) control on the call-rate by Domoticz, but the call-rate by the lua-scripts can be manipulated in the script.
Emperically I found a setting for the call-rate of the scripts of approx. 15 to 20 minutes, which in combination with the call-rate by Domoticz does not exceed the daily limit. Apparently, splitting the 2 accounts to 2 API-keys does not make difference.

;-) very ROM deduction, but if I take 15 minutes as reference, it means that those 2 lua-scripts daily take approx. 2*24*4 calls = 192 calls, leaving a space of approx. 300 calls/day for Domoticz' requests, and for my calls to 2 accounts that is equivalent to 10min interval per call per account, confirming mivo's observation.
Then surprising that with calls from Domoticz to 1 WU-account you exceed the daily allowed volume.
:-( Apparently we are missing something ..........

As experienced/observed, all accumulated calls to your WUnderground-API are counted, whether from Domoticz or from elsewhere.
Some aspects to check in that perspective?
1) Did you apply something like this to make a connection between Evohome and WUnderground? Would not be surpised if that requires extra calls to WUnderground.
2) (Perhaps far-fetched), what is your polling interval for Evohome: it should be >120s. (see Domoticz' Wiki on Evohome)

On the other hand, you also get an Alert-message in case of >10 calls per minute (in combination with free WU-membership), and therefore a few 'bursts' may trigger WUnderground for an alert (although I do not see how that could happen in your case).
Last edited by Toulon7559 on Thursday 17 August 2017 17:37, edited 1 time in total.
Set1 = RPI-B+RFXCom433+S0PCM+Linksprite-shield for BMP180/DS18B20/RS485+DDS238ZN1
Set2 = RPI-3+RFLinkGTW+ESP8266s+PWS_WS7000
Common = 2*PVLogger+PWS_TFA_Nexus+KAKUs
=> Energy & Data Management based on Time and on PV&Consumption&Meteo

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Tuesday 01 August 2017 16:51

Hello All

I do not have almost any scripting skills. I consider my self an average user :)
So no script making additional calls to WU.
I do not use ifttt.
Evohome is not calling WU.

I have the Domoticz on my desktop PC and it works fine for me and I do not know is the script for WU restarting but as long as I can tell the Domoticz do not restart.
I might need to try to do a Linux VM and install it on it and see how it goes there.

Thank you all for trying to help.

Ajderev
Posts: 11
Joined: Thursday 27 July 2017 17:08
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by Ajderev » Saturday 05 August 2017 0:42

I installed Ubuntu 16.04 on VM and installed Domoticz and I still have the same issue.

I think the issue is that every time Evohome via Web API pulls data the Domoticz restart.

Aug 4 23:35:42 Domotixz domoticz[3648]: 2017-08-04 23:35:42.865 (Evohome) fetch data from server
Aug 4 23:35:42 Domotixz kernel: [ 4155.997270] domoticz[3659]: segfault at 8 ip 0000000000970675 sp 00007f6e1626a710 error 4 in domoticz[400000+94e000]
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Main process exited, code=killed, status=11/SEGV
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Unit entered failed state.
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Failed with result 'signal'.
Aug 4 23:36:42 Domotixz systemd[1]: domoticz.service: Service hold-off time over, scheduling restart.
Aug 4 23:36:42 Domotixz systemd[1]: Stopped domoticz_service.
Aug 4 23:36:42 Domotixz systemd[1]: Started domoticz_service.
Aug 4 23:36:42 Domotixz domoticz[3712]: 2017-08-04 23:36:42.988 Domoticz V3.8153 (c)2012-2017 GizMoCuz
Aug 4 23:36:42 Domotixz domoticz[3712]: 2017-08-04 23:36:42.988 Build Hash: 494fff71, Date: 2017-07-30 11:19:41

Is omeone else using Evohome via Web API axpirience the same issue ?

vosmanz
Posts: 1
Joined: Wednesday 22 June 2016 13:26
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by vosmanz » Thursday 10 August 2017 10:23

Since a couple of days i have a simular issue.
Every night I get an e-mail with the message:
Your wunderground API key (*key here*) exceeded its allotted usage today by making 20 calls within a minute but the limit is 10.
...
Details: exceededrate: maxrate: 20 (of 10)
Time: Thu, Aug 10, 2017 00:00 UTC
Not sure if it is related, but I recently updated to build V3.8153. I'm using the package on my Synology NAS. It has been running ok for a long time (temperature log goes back to nov. 2015) without any changes. Data timeout is disabled in the settings.

Anyone else with this issue, and does anyone know how to fix it?

dws199
Posts: 8
Joined: Sunday 17 January 2016 15:11
Target OS: Windows
Domoticz version:
Contact:

Re: wunderground API usage alert

Post by dws199 » Tuesday 15 August 2017 16:57

Ajderev wrote:
Saturday 05 August 2017 0:42
I installed Ubuntu 16.04 on VM and installed Domoticz and I still have the same issue.

I think the issue is that every time Evohome via Web API pulls data the Domoticz restart.

Aug 4 23:35:42 Domotixz domoticz[3648]: 2017-08-04 23:35:42.865 (Evohome) fetch data from server
Aug 4 23:35:42 Domotixz kernel: [ 4155.997270] domoticz[3659]: segfault at 8 ip 0000000000970675 sp 00007f6e1626a710 error 4 in domoticz[400000+94e000]
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Main process exited, code=killed, status=11/SEGV
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Unit entered failed state.
Aug 4 23:35:42 Domotixz systemd[1]: domoticz.service: Failed with result 'signal'.
Aug 4 23:36:42 Domotixz systemd[1]: domoticz.service: Service hold-off time over, scheduling restart.
Aug 4 23:36:42 Domotixz systemd[1]: Stopped domoticz_service.
Aug 4 23:36:42 Domotixz systemd[1]: Started domoticz_service.
Aug 4 23:36:42 Domotixz domoticz[3712]: 2017-08-04 23:36:42.988 Domoticz V3.8153 (c)2012-2017 GizMoCuz
Aug 4 23:36:42 Domotixz domoticz[3712]: 2017-08-04 23:36:42.988 Build Hash: 494fff71, Date: 2017-07-30 11:19:41

Is omeone else using Evohome via Web API axpirience the same issue ?
Hi

I have exactly the same issue as you and my setup is very similar, running the latest version of Domoticz on a Windows 10 machine with Evohome Web API device. I'm receiving regular emails from Wunderground too so have disabled the service for now.

If it is evohome causing the restarts then the only workaround that I can think of is to setup another Domoticz instance instance (on a rpi) for example and have that as a slave device to the main Domoticz device. This slave could then be used purely for evohome devices.

Dave

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests