Get rid of "evohome Devices" writing from dashboard

Deuteros
Posts: 7
Joined: Wednesday 30 November 2016 11:36
Target OS: Linux
Domoticz version: V3.5877
Location: Italy
Contact:

Get rid of "evohome Devices" writing from dashboard

Postby Deuteros » Tuesday 13 December 2016 13:43

Hello guys,
  in my Domoticz system I implemented the control of my Honeywell EvoHome WiFi via script ( https://www.domoticz.com/wiki/Evohome#S ... _or_RFG100 ).

Everything works fine except for a boring detail. :|

Despite not having entered my EvoHome Touch as a preferred device, the dashboard shows the writing evohome Devices

evohome_Devices.png
evohome_Devices.png (25.98 KiB) Viewed 496 times

Does anyone know how to remove this writing?

Thanks!

stlaha2007
Posts: 414
Joined: Monday 05 October 2015 10:16
Target OS: -
Domoticz version:
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby stlaha2007 » Sunday 18 December 2016 11:48

I see your using a custom template...

Try to set your Dashboard to "Compact" in settings. I'm using that myself in the default....

Or:
Debug/Inspect the Dashboard page with your browser and find the block displaying the Header-Rows. When you're sure thats the one. Eg. FireFox allows you to modify WYSIWYG-like, to see the result immediatly.

Then go to the domoticz/www/styles/$TEMPLATENAME/custom.css. Open the .css and search for or add the code to the .css-file to get rid of all those headers...


Sent from my K00C using Tapatalk

Deuteros
Posts: 7
Joined: Wednesday 30 November 2016 11:36
Target OS: Linux
Domoticz version: V3.5877
Location: Italy
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby Deuteros » Monday 19 December 2016 13:09

Hi stlaha,
I've tried to choose a different template and also tried to set "Compact" but nothing. :cry:

I've found the header block, but it's the same H2 used for the other headers.

Chrome.PNG
Chrome.PNG (34.06 KiB) Viewed 464 times

stlaha2007
Posts: 414
Joined: Monday 05 October 2015 10:16
Target OS: -
Domoticz version:
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby stlaha2007 » Monday 19 December 2016 15:43

Thats correct...
Personally i know which 'widget' is which (switch/temp/weather).
So i removed them 'completly' witth css. I thought Compact mode dropped the also, but thats my mistake perhaps.

Another way is kind of tricky, did it before last update, and now lost it that way. Is to dive into the dashboard.js code. That part is responsible to build the content where you did find the H2 header. And add a class specific to that row, which you can call in .css.

So for the moment, you have 2 options disable/hide all h2 headers with css, or wait (a lot would love to see it) till all details are filled with classes so editing css would make much more sense ;-)

Deuteros
Posts: 7
Joined: Wednesday 30 November 2016 11:36
Target OS: Linux
Domoticz version: V3.5877
Location: Italy
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby Deuteros » Tuesday 20 December 2016 12:52

After some tests I noticed that the written appears only if the temperature of a zone is set as favorite.

Apparently there is something wrong in the creation of EvoHome zones: they are displayed as temperature devices, but they are also classified as "evohome Devices".

I poked around in the evo-update.sh script and the zones are created in Domoticz as a type 70 device.

We should modify the definition of this type of device in the Domoticz code and classify it in a different manner...

stlaha2007
Posts: 414
Joined: Monday 05 October 2015 10:16
Target OS: -
Domoticz version:
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby stlaha2007 » Wednesday 28 December 2016 9:37

Sounds interesting... Perhaps its based on the assumption that if you have temperature from a zone, you 'want also' the controller for that zone?

Should be easy to correct then. By creation of a second temp-device, update that one with the evo-temp-device, and set this new one as favorite instead of the evo-temp.

Reminds me that i also created a few evo-devices by hand and afterwards removed the favorite setting.

stlaha2007
Posts: 414
Joined: Monday 05 October 2015 10:16
Target OS: -
Domoticz version:
Contact:

Re: Get rid of "evohome Devices" writing from dashboard

Postby stlaha2007 » Wednesday 28 December 2016 9:50

I found out it (at least) depends on the temp-setpoint device. I removed the favo from this, and its gone.

I also created this one, specific to get temps and setpoint correlation in customgraphs at the temp-tab.

Now its solved for me, at least ;-)


Return to “Temperature and Weather”

Who is online

Users browsing this forum: No registered users and 2 guests