Sensor for rain and wind not created

Post Reply
Wroopy
Posts: 12
Joined: Tuesday 18 October 2016 22:06
Target OS: Linux
Domoticz version: v3.5745
Contact:

Sensor for rain and wind not created

Post by Wroopy » Sunday 30 October 2016 18:54

Hi,

I've just started to use Domoticz. Devices for rain and wind is not created. The devices are from Oregon WMR200 and are collected via Tellstick. I've been using version 5745 and just upgraded to 5838.

The readings is found and decoded, but a sensor is not created. What do I need to do to create the devices?
I've got four temperature/humidity sensors and they are working, both from Oregon and other.

Based on the log (see below), it looks like the data is recieved and decoded right.

Oregon, Wind meter, no sensor created

Code: Select all

2016-10-30 17:43:21.056 Tellstick: rawDeviceEvent 1: class:sensor;protocol:oregon;model:1984;id:17;winddirection:337.5;windaverage:0.0;windgust:0.0;
2016-10-30 17:43:21.056 Tellstick: sensorEvent 17,oregon,1984,16,337.5
2016-10-30 17:43:21.056 Tellstick: sensorEvent 17,oregon,1984,32,0.0
2016-10-30 17:43:21.056 Tellstick: sensorEvent 17,oregon,1984,64,0.0
Oregon, Rain meter, no sensor created

Code: Select all

2016-10-30 17:44:35.770 Tellstick: rawDeviceEvent 1: class:sensor;protocol:oregon;model:2914;id:15;raintotal:767.8;rainrate:0.0;
2016-10-30 17:44:35.770 Tellstick: sensorEvent 15,oregon,2914,4,0.0
2016-10-30 17:44:35.770 Tellstick: sensorEvent 15,oregon,2914,8,767.8
Oregon, Temp/humidity sensor, works fine

Code: Select all

2016-10-30 17:43:42.336 Tellstick: rawDeviceEvent 1: class:sensor;protocol:oregon;model:F824;id:10;temp:5.3;humidity:74;
2016-10-30 17:43:42.336 Tellstick: sensorEvent 10,oregon,F824,1,5.3
2016-10-30 17:43:42.336 Tellstick: sensorEvent 10,oregon,F824,2,74
Oregon, Temp/humidity sensor, works fine

Code: Select all

2016-10-30 17:43:43.504 Tellstick: rawDeviceEvent 1: class:sensor;protocol:oregon;model:F824;id:12;temp:5.6;humidity:65;
2016-10-30 17:43:43.504 Tellstick: sensorEvent 12,oregon,F824,1,5.6
2016-10-30 17:43:43.504 Tellstick: sensorEvent 12,oregon,F824,2,65
Other, Temp/humidity sensor, works fine

Code: Select all

2016-10-30 17:43:42.544 Tellstick: rawDeviceEvent 1: class:sensor;protocol:fineoffset;id:135;model:temperaturehumidity;humidity:64;temp:9.8;
2016-10-30 17:43:42.544 Tellstick: sensorEvent 135,fineoffset,temperaturehumidity,1,9.8
2016-10-30 17:43:42.544 Tellstick: sensorEvent 135,fineoffset,temperaturehumidity,2,64
Other, Temp/humidity sensor, works fine

Code: Select all

2016-10-30 17:44:05.351 Tellstick: rawDeviceEvent 1: class:sensor;protocol:mandolyn;id:11;model:temperaturehumidity;temp:22.3;humidity:55;
2016-10-30 17:44:05.351 Tellstick: sensorEvent 11,mandolyn,temperaturehumidity,1,22.3
2016-10-30 17:44:05.351 Tellstick: sensorEvent 11,mandolyn,temperaturehumidity,2,55
/Andreas

Mheel
Posts: 1
Joined: Sunday 30 October 2016 13:46
Target OS: Linux
Domoticz version:
Contact:

Re: Sensor for rain and wind not created

Post by Mheel » Wednesday 15 March 2017 20:00

Did you get it to work?
I have the same problem.

Wroopy
Posts: 12
Joined: Tuesday 18 October 2016 22:06
Target OS: Linux
Domoticz version: v3.5745
Contact:

Re: Sensor for rain and wind not created

Post by Wroopy » Tuesday 02 May 2017 8:36

Mheel wrote:Did you get it to work?
I have the same problem.
Didn't see your question until today. I made a change in the source for reading from tellstick and after that change Rain and wind is handled.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest