Aeotec KeyFob switch commands don't work

Post Reply
wile
Posts: 5
Joined: Tuesday 20 December 2016 22:54
Target OS: -
Domoticz version:
Contact:

Aeotec KeyFob switch commands don't work

Post by wile » Tuesday 20 December 2016 23:10

Hi,
I've successfully included the 4 button key fob and changed to scene mode (took me some time to get so far).

The key fob switch is displayed as dimmer switch in Domoticz. By pressing the buttons on the key fob, I can see log entries like
2016-12-20 21:47:33.133 (Razberry) Light/Switch (Unknown)
2016-12-20 21:47:33.138 (Razberry) Light/Switch (Unknown)
2016-12-20 21:47:35.845 (Razberry) Light/Switch (Unknown)
2016-12-20 21:47:35.848 (Razberry) Light/Switch (Unknown)
2016-12-20 21:48:33.344 (Razberry) Light/Switch (Unknown)

However, the switch button in the GUI don't change. Actually, the buttons should send values:
Button 1 short press = 1
Button 1 long press = 2
Button 2 short press = 3
Button 2 long press = 4
Button 3 short press = 5
Button 3 long press = 6
Button 4 short press = 7
Button 4 long press = 8

But the switch keeps off. Any ideas to get this working?

Thanks
wile

wile
Posts: 5
Joined: Tuesday 20 December 2016 22:54
Target OS: -
Domoticz version:
Contact:

Re: Aeotec KeyFob switch commands don't work

Post by wile » Friday 23 December 2016 12:23

Sloved this now on my own.

Fyi, while there is only one selector switch in the device overview after inclusion, after some time switches representing the buttons are added in addition. Note, that these are always on, however, while pressing the button a On-Event is triggered.

Best
wile

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests