Search found 10 matches

by darknico31
Saturday 30 January 2016 11:38
Forum: Suggestions
Topic: Mode-selector / multistate device
Replies: 104
Views: 32194

Re: Mode-selector / multistate device

EDIT :
Cache issue, nothing to see here :oops:
(not refreshing even with CTRL-F5)
by darknico31
Friday 20 November 2015 11:27
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

I've done some tests yesterday. It acted weird at first but it seems ok now. First restart after compiling, I've not looked on the logs, but it was connected. When I came home, I reset the gateway and waited for the keepalive to do is job, but nothing happened (I've waited at least 5min). So I decid...
by darknico31
Thursday 19 November 2015 10:28
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

I've just compiled a fresh 3608. I'm not a home, so I have no way to shutdown the ethernet gateway to test. I'll will test as soon as a get home. I'll keep you informed. Speeking of 1.6, the other day, in have found a page that explained how to modify 1.5 sketch to be 1.6. I don't find it anymore. D...
by darknico31
Wednesday 18 November 2015 23:19
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

Nice, I didn't know about the I_HEARTBEAT message.
Is this a mysensors 1.6 thing ?
Because it's not referenced here :
http://www.mysensors.org/download/serial_api_15
In your code you use internal code 18, and the documentation stop at 17.
by darknico31
Wednesday 18 November 2015 0:20
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

If by ping/pong you mean icmp ping. I don't think it could work. Because if you ping lets say, every minute, the gateway boot time is so fast that you will never miss a ping. And after restart, the telnet connection will be dead but the ping ok. I dug a little more about W5100 keepalive. it seems to...
by darknico31
Tuesday 17 November 2015 20:22
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

It's nice that you fixed the version "problem". Data timeout will work, but it's not very "clean". If we don't have sensors and only actuator, it will not work. Maybe we can work on some keepalive ? A quick google search confirm that W5100 support sending keepalive. I'll try to mod the gateway sketc...
by darknico31
Tuesday 17 November 2015 11:36
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

I can confirm I have the same behavior.
I have to restart domoticz when I restart my Ethernet gateway.
Also available to assist :)

Edit: A workaround would be to set a data timeout on the ethernet gateway.
But, it's not the good way to do that.
by darknico31
Saturday 14 November 2015 12:26
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

It's ok for me.
2.3589 / 371d507
Thanks Gizmocuz
by darknico31
Friday 13 November 2015 23:14
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

If you refer to this commit "MySensors better support for multiple gateways".

I only have one gateway and I have the "duplication" problem.

I will test to recompile tomorrow and test if anything change.
by darknico31
Friday 13 November 2015 13:22
Forum: MySensors
Topic: MySensors - Gateway to Domoticz
Replies: 311
Views: 102099

Re: MySensors - Gateway to Domoticz

Hi,

Could it be the same problem I described here ?
http://www.domoticz.com/forum/viewtopic.php?f=6&t=8848