Search found 58 matches

by BazsoDombiAndras
Thursday 01 February 2018 12:37
Forum: Bugs and Problems
Topic: error while loading shared libraries: libudev.so.1:
Replies: 36
Views: 8326

Re: error while loading shared libraries: libudev.so.1:

Same problem here. Tried to update to the latest beta and since then I have this problem.

libudev is installed and at the latest version.

Using Raspbian on a Raspberry Pi 2.
by BazsoDombiAndras
Tuesday 07 November 2017 9:09
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Thank you!

I might give monit a try, although I've never used it, but hey, there's a first time for everything...

I'm kind of hoping that the devs will chime in at some point and give me some "official" guidance on how to figure this out...
by BazsoDombiAndras
Friday 03 November 2017 23:03
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Well, I can't update to beta anyway... so I have no idea how to make it work in a stable manner...
by BazsoDombiAndras
Friday 03 November 2017 8:25
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Thank you for your help, jeanclic! The icons are gone during every update because www/switch_icons.txt is always overwritten and it doesn't even make a backup... Trying to update via the web page results in the very same error as running "updatebeta". I prefer running the script though because updat...
by BazsoDombiAndras
Friday 03 November 2017 7:29
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

After about 3-4 days Domoticz stopped working again, so I went ahead and ran the "updatebeta" script. Now it won't even start :( error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory Running "updaterelease" fixed it and it's working, but I assu...
by BazsoDombiAndras
Thursday 02 November 2017 9:54
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Thanks, EddyG!

For now I've disabled all restarting to see how much it works on its own, next step will be updating to beta. However I doubt that the current stable version's leak is my problem, because this problem has been around for me in previous versions as well.
by BazsoDombiAndras
Thursday 02 November 2017 9:13
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Thank you, jeanclic!

I can't disable the events because there's way too much automation in my house relying on it, but I'll try updating to the latest beta.
I did try restarting domoticz every night through a cron job, but I'm not sure if it was actually doing it...
by BazsoDombiAndras
Thursday 02 November 2017 7:56
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

What makes you think the SD card is the problem? I doubt that this could be the problem... everything else that runs on that Pi works perfectly fine, except Domoticz...
by BazsoDombiAndras
Tuesday 31 October 2017 14:38
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

I'm not sure that multiple domoticz processes are running. Yes, htop shows quite a list, as shown on the above screenshot, but if I do "ps -aux | grep domoticz", it only gives me one result...

It seems to me that domoticz is started from /etc/init.d/domoticz.sh.
by BazsoDombiAndras
Tuesday 31 October 2017 12:40
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

The Motherboard sensors section does not show anything...
DomoMBSensors.jpg
DomoMBSensors.jpg (109.14 KiB) Viewed 1958 times
by BazsoDombiAndras
Tuesday 31 October 2017 11:02
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

So it's not ok to see all those domoticz processes started after all... hmm... interesting...
I have no idea whatsoever what starts domoticz and why it starts it many times, but I'll investigate and find out. What is stretch?

Thanks!
by BazsoDombiAndras
Tuesday 31 October 2017 9:50
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Well, it does not seem to be using much memory (It's been running for about 12 hours I think), but I find it strange that the service is started multiple times... or is this not what I'm seeing here?
htop.png
htop.png (83.27 KiB) Viewed 1998 times
by BazsoDombiAndras
Tuesday 31 October 2017 9:44
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Re: Help: Why is Domoticz crashing all the time?

Thanks, I'll keep an eye on the memory usage... perhaps it has something to do with it?
by BazsoDombiAndras
Tuesday 31 October 2017 9:33
Forum: Bugs and Problems
Topic: Help: Why is Domoticz crashing all the time?
Replies: 22
Views: 2887

Help: Why is Domoticz crashing all the time?

Hi! I've been running Domoticz on a Raspberry Pi for about 3 years now (and I keep updating it to newer versions). Ever since the beginning it has been crashing regularly. Well, I don't know if it's a crash per se, but every 1-2-3 days Domoticz just stops working and I have to restart the service to...
by BazsoDombiAndras
Thursday 03 August 2017 13:00
Forum: Bugs and Problems
Topic: Updating TEXT sensor doesn't work anymore
Replies: 9
Views: 905

Re: Updating TEXT sensor doesn't work anymore

Yeah.. well, I still would like to know why it happened...
With this replace functionality do you get the keep the sensor history and the presence of the sensor in Dashboard and floor plans?
by BazsoDombiAndras
Thursday 03 August 2017 12:35
Forum: Bugs and Problems
Topic: Updating TEXT sensor doesn't work anymore
Replies: 9
Views: 905

Re: Updating TEXT sensor doesn't work anymore

While trying to delete the virtual sensors which were of type text, I realized that for each of them a new one has appeared in the list of devices with new index! It seems that the Domoticz update has somehow created new virtual sensors instead of the existing ones, but obviously I did not know abou...
by BazsoDombiAndras
Thursday 03 August 2017 12:31
Forum: Bugs and Problems
Topic: Updating TEXT sensor doesn't work anymore
Replies: 9
Views: 905

Re: Updating TEXT sensor doesn't work anymore

Yepp, this is the catch! It works for a new sensor but it doesn't work for an old one. I remember that I had the same problem about a year go for different virtual sensors in Domoticz. So I eneded up re-creating them. It seems like this is what I'll have to do now too. But it also means that you hav...
by BazsoDombiAndras
Thursday 03 August 2017 12:21
Forum: Bugs and Problems
Topic: Updating TEXT sensor doesn't work anymore
Replies: 9
Views: 905

Re: Updating TEXT sensor doesn't work anymore

I tried again manually entering the URL, it still doesn't work. The sent response is OK but the device is not updated. I checked the index too, it's correct. I'm running this update every minute from a script and it worked fine for a long time, then it stopped working when I installed the update.
by BazsoDombiAndras
Thursday 03 August 2017 10:12
Forum: Bugs and Problems
Topic: Updating TEXT sensor doesn't work anymore
Replies: 9
Views: 905

Updating TEXT sensor doesn't work anymore

Version: 3.8153 Platform: Raspbian Plugin/Hardware: Raspberry Pi 2 Description: Updating a TEXT sensor's value through the JSON API is broken. 192.168.0.x/json.htm?type=command¶m=udevice&idx=80&nvalue=0&svalue=SomeValue This doesn't work anymore in v3.8153. Used to work just fine in an older ver...
by BazsoDombiAndras
Monday 30 January 2017 13:28
Forum: Suggestions
Topic: Netatmo thermostat support
Replies: 43
Views: 13894

Re: Netatmo thermostat support

I've tried this from LUA: commandArray[0]={['UpdateDevice']='ThermostatDeviceIdx|1|17.5'} The setpoint temperature is modified to 17.5 degrees as requested, but the thermostat state is not modified to Away as requested. It seems that changing the thermostat state from LUA or JSON does not work at all.