Search found 1152 matches

by jvdz
Wednesday 14 November 2018 15:38
Forum: Bugs and Problems
Topic: P1 information not coming through with cable splitter
Replies: 4
Views: 69

Re: P1 information not coming through with cable splitter

Doubt you can simply split a serial connection so 2 device can start the same type of terminal session to retrieve data.
It is more likely you have one device pull the data and then share the retrieved data from that device.

Jos
by jvdz
Tuesday 13 November 2018 11:07
Forum: Bugs and Problems
Topic: only errors in the log, please HELP me
Replies: 2
Views: 160

Re: only errors in the log, please HELP me

Did you stop the domoticz service before running ./domoticz as it could be the service is still running and locking the database?

Jos
by jvdz
Sunday 11 November 2018 14:48
Forum: General Discussion
Topic: All json commands stopped working
Replies: 14
Views: 301

Re: All json commands stopped working

Sure that makes sense as I already mentioned earlier... your source IP is local when you do that. One thing you could do to make things clearer is to start showing the result for this command to be ran from your PI: traceroute google.com We can continue this in PM in case you don't want to post this...
by jvdz
Sunday 11 November 2018 13:44
Forum: General Discussion
Topic: All json commands stopped working
Replies: 14
Views: 301

Re: All json commands stopped working

You are probably doing a double NAT now. The internet is connected to the Deutsche Glasfaser Router, which is using its own NATting and has presumably an DHCP server and WiFi for the internal network? is your Domoticz now connected to the IP of the Deutsche Glasfaser router?

Jos
by jvdz
Sunday 11 November 2018 0:55
Forum: General Discussion
Topic: All json commands stopped working
Replies: 14
Views: 301

Re: All json commands stopped working

Hi Jos, you have a point there... -snip- What can I do? Like I said, did you add the port-forward in your new glass internet router? When you try from the internal network, it makes sense that things work as your source IP is local so no NAT with port-forward is required. (sorry for the tech lingo ...
by jvdz
Saturday 10 November 2018 19:58
Forum: General Discussion
Topic: All json commands stopped working
Replies: 14
Views: 301

Re: All json commands stopped working

And you are not connected to your LAN at that time but use mobile data on the internet?

Jos
by jvdz
Saturday 10 November 2018 19:35
Forum: General Discussion
Topic: All json commands stopped working
Replies: 14
Views: 301

Re: All json commands stopped working

Sounds like the PortForward to domoticz isn't setup yet in your new router, or maybe your external IP address changed?

Jos
by jvdz
Wednesday 07 November 2018 17:27
Forum: Speech & Voice Systems
Topic: Node Red / google home
Replies: 3
Views: 208

Re: Node Red / google home

Nice ... I was looking for a direct integration with Google Home and this works nicely. ... thanks for sharing.
Do you also know of a way that you can give commands directly without first "praat met ...." ?

Jos
by jvdz
Tuesday 06 November 2018 11:18
Forum: Switches and Scenes
Topic: Scene trigger not working
Replies: 6
Views: 133

Re: Scene trigger not working

Are you using a Userid/Password login for your domoticz?
You could change the url to: http://127.0.0.1:8080/json.htm?type=com ... cmd=Toggle
..and ensure that 127.0.0.1 is in the Local Networks field in your setup. This avoids any need for UserId/Password.

Jos
by jvdz
Monday 05 November 2018 19:25
Forum: Switches and Scenes
Topic: Scene trigger not working
Replies: 6
Views: 133

Re: Scene trigger not working

What does the domoticz log show at the time the dummy is switched? Any errors for the On/Off actions?

Jos
by jvdz
Sunday 04 November 2018 13:40
Forum: Z-Wave
Topic: Cheap chinese z-wave products
Replies: 563
Views: 109115

Re: Cheap chinese z-wave products

Not really ZWave I guess but rather Wifi. :)

Jos
by jvdz
Thursday 01 November 2018 10:01
Forum: Bash / PowerShell / Batch etc.
Topic: script for presence detection of a phone
Replies: 49
Views: 17768

Re: script for presence detection of a phone

hi all, i'm getting the following - -snip- raise HTTPError(req.get_full_url(), code, msg, hdrs, fp) urllib2.HTTPError: HTTP Error 401: Unauthorized using the script from - https://www.domoticz.com/wiki/Presence_detection#Installing_Python Are you using Domoticz web access with UserId & Password as ...
by jvdz
Sunday 28 October 2018 20:51
Forum: LUA
Topic: Script LUA to read value on a webpage ?
Replies: 8
Views: 360

Re: Script LUA to read value on a webpage ?

Are you using Userid/Password security for Domoticz? When the script is running on the same server you could make the url: response, status = http.request('http://127.0.0.1:8080/json.htm?type=command¶m=udevice&idx=7180&nvalue=0&svalue=500') And make sure the 127.0.0.1 is in the Setup/Settings pa...
by jvdz
Sunday 28 October 2018 19:47
Forum: LUA
Topic: Script LUA to read value on a webpage ?
Replies: 8
Views: 360

Re: Script LUA to read value on a webpage ?

Abuse huh? :)

You really will have to provide the script with the code you tried to be able to see what could be wrong.
Also tell me what type of dummy device you try to update? (text?)

Jos
by jvdz
Sunday 28 October 2018 12:58
Forum: Third party and supplementary tools
Topic: dtgbot - Domoticz TeleGram BOT
Replies: 307
Views: 50992

Re: dtgbot - Domoticz TeleGram BOT

So that would mean it can't connect to the domoticz server to retrieve the variable. Are you sure the serversettings are done correctly? Are you user Userid/Password for access to domoticz? Could you show the whole dtgbot.log so I can have a look to see if that looks correct? ( you can also PM in ca...
by jvdz
Sunday 28 October 2018 11:27
Forum: Third party and supplementary tools
Topic: dtgbot - Domoticz TeleGram BOT
Replies: 307
Views: 50992

Re: dtgbot - Domoticz TeleGram BOT

You need to set the UserVariable TelegramBotOffset on the new System to the same value as the old system as that is the message sequencenumber for the received commands it is try to read. You probably can't use the both at the same time, but it should work when the old system's dtgbot is stopped.! Jos
by jvdz
Saturday 27 October 2018 18:51
Forum: LUA
Topic: Script LUA to read value on a webpage ?
Replies: 8
Views: 360

Re: Script LUA to read value on a webpage ?

Look at DTGBOT installation in the wiki, which has a download for it and tells you where it needs to be located. :) Edit: this is the forum post with links: http://domoticz.com/forum/viewtopic.php?f=21&t=7279&hilit=Dtgbot Wiki link: https://www.domoticz.com/wiki/Remote_Control_of_Domoticz_by_Telegra...
by jvdz
Friday 26 October 2018 17:37
Forum: Others
Topic: P1 Smart Meter hardware (x) thread seems to have ended unexpectedly
Replies: 2
Views: 483

Re: P1 Smart Meter hardware (x) thread seems to have ended unexpectedly

I have had the same and for me the WiFi connection was lost. As Domoticz keeps the connection open constantly waiting for data it would fail after this dreconnect of the ESP. I am on 4.9700, which has some issues when the thread fails it will get somewhat unstable. Think this is worked on in Beta bu...
by jvdz
Tuesday 23 October 2018 22:56
Forum: Bugs and Problems
Topic: Multiple errors
Replies: 3
Views: 157

Re: Lua errors

You probably need to check the CAPS of the lua scriptline including the JSON.lua to match this

Jos
by jvdz
Thursday 18 October 2018 18:03
Forum: LUA
Topic: Script LUA to read value on a webpage ?
Replies: 8
Views: 360

Re: Script LUA to read value on a webpage ?

It is actually pretty strait forward to do this. This script requires LUA socket.http to be installed: DEVIDX=123 weburl='http://www.laghi.net/homepage.aspx?tab=3&subtab=2&idlago=3' domurl='http://192.168.0.xx:8080/json.htm?type=command¶m=udevice&idx=' .. DEVIDX .. '&nvalue=0&svalue=' -- retriev...