Search found 650 matches

by jannl
Tuesday 10 April 2018 18:54
Forum: Other questions and discussions
Topic: Water Leak / Flood Sensor?
Replies: 11
Views: 1280

Re: Water Leak / Flood Sensor?

Hm. Ok. I see mine is an on/off. I do not really care. It is handled in lua and sends me a notification.
by jannl
Tuesday 10 April 2018 7:36
Forum: Other questions and discussions
Topic: Water Leak / Flood Sensor?
Replies: 11
Views: 1280

Re: Water Leak / Flood Sensor?

Sure there are. Got a zwave myself. Look robbshop I think I bought there.
by jannl
Saturday 31 March 2018 10:16
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

This is probably because during installation some settings where made taking care of using the correct output as a default.

Thisis why I told you to investigate that. During script execution in this way the normal user settings are not present. The same counts for instance for crontab scripts.

Jan
by jannl
Saturday 31 March 2018 10:09
Forum: Other questions and discussions
Topic: database disk image is malformed
Replies: 2
Views: 693

Re: database disk image is malformed

Normally a csv export import fixes this. Please search the forum (or internet) for the exact steps
by jannl
Sunday 25 March 2018 10:59
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Debugging in linux can be a pain in the ass
by jannl
Sunday 25 March 2018 10:59
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Looks like an error in the script or calling the script
by jannl
Sunday 25 March 2018 10:47
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

What do mean?

If you mean set > filename.log. add that to the log and replace filename.log with a path and filename the user the script runs under has write rights.
by jannl
Sunday 25 March 2018 10:12
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Hm. I agree. Looks like it is working. Not sure if it is a volume issue. Can you set the volume from the script?

set > filename.log sends the output of set toba file. Same for setenv
by jannl
Sunday 25 March 2018 8:49
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Read the posts regarding the path settings. Make sure all path settings and environment settings are the same in the command line and in the script. They are different depending on the way the script is started. Either direct from commandline or via Domoticz. This is linux, not windows. Redirecting ...
by jannl
Friday 23 March 2018 16:40
Forum: General Discussion
Topic: Install Domoticz on new raspbian/debian stretch
Replies: 40
Views: 36882

Re: Install Domoticz on new raspbian/debian stretch

My init.d script is run as root. 443 is allowed then.
by jannl
Friday 23 March 2018 16:37
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

The path ezsynth inside the script. The script itself is executed as shown in the Domoticz log
by jannl
Friday 23 March 2018 16:34
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

The error ia not in Domoticz. The script has an error (i think). If Domoticz had an error it would be in the logging. Just try adding the complete path to the binary in the script.
by jannl
Friday 23 March 2018 16:30
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

The script most likely has no path (or did you check). Try using the complete path to the binary.
by jannl
Friday 23 March 2018 16:27
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Hm. Read what I wrote. Off course Domoticz executes the script. You entered the path. The script itself propably does not find the binary you try to call. Not sure what you know about how linux works, but when a shell is forked (what happens when executing the script like this), most likely that she...
by jannl
Friday 23 March 2018 16:18
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

I mean the path settings in the script. Does the script find everything it needs?
by jannl
Friday 23 March 2018 16:08
Forum: LUA
Topic: Lua script executing sh script... not working!
Replies: 39
Views: 2676

Re: Lua script executing sh script... not working!

Not only access rights, also path settings and environment vars (if used) should be checked.

Besides, as far as I can see I do not see an error.....
by jannl
Thursday 01 March 2018 8:27
Forum: Bash / PowerShell / Batch etc.
Topic: Different Backups from Crontab to network
Replies: 79
Views: 21732

Re: Different Backups from Crontab to network

I recently saw the same error on this forum. It has something to do withe the active passive setting of ftp. Please search.
by jannl
Thursday 01 March 2018 8:19
Forum: Bugs and Problems
Topic: Domoticz offline
Replies: 12
Views: 1942

Re: Domoticz offline

Use an usb stick, an external hd or switch to overlayfs.
Prevents you sd card from getting corrupted.
by jannl
Saturday 17 February 2018 19:01
Forum: News & Updates
Topic: Domoticz version 3.8153 released (Stable)
Replies: 201
Views: 172872

Re: Domoticz version 3.8153 released (Stable)

./updaterelease in the domoticz directory does not work? Or do you not have a domoticz installation?
by jannl
Friday 16 February 2018 18:04
Forum: Other questions and discussions
Topic: RPi SD card duplicate
Replies: 17
Views: 1531

Re: RPi SD card duplicate

Connecting a monitor and checking the errors is a way to go from here