OpenWebNet developing..?

Others (MiLight, Hue, Toon etc...)
dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Saturday 03 February 2018 12:43

@spugna85
Here a Screenshot of the log, not sure it this comes from the audio devices.

I have the mh202 as gateway.

Thanks
MartinImage

Gesendet von meinem BLA-L29 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Saturday 03 February 2018 13:00

Ok but this does not help me.
I need the status messages received, for example:

received = *#18*51*5*126042##: MEASURE FRAME

In this example, 18 is the WHO related to energy.

I need messages containing 22 or 16:
22 is the WHO relating to sound diffusion
16 is the WHO related to audio system

Thanks

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Saturday 03 February 2018 13:06

Sorry, here you are.

Thanks Image

Gesendet von meinem BLA-L29 mit Tapatalk


dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Friday 09 March 2018 15:12

Hello spugna85,

Do you work on integration of bticino audio system?

Only for information.

Thanks
Martin

Gesendet von meinem ONEPLUS A5010 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Friday 09 March 2018 15:33

dimk wrote:
Friday 09 March 2018 15:12
Hello spugna85,

Do you work on integration of bticino audio system?

Only for information.

Thanks
Martin

Gesendet von meinem ONEPLUS A5010 mit Tapatalk
Unfortunately I could not work on the integration of the audio system because I was very busy with other work.
I hope I can work on this soon.

PicciGabber
Posts: 4
Joined: Wednesday 14 March 2018 22:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by PicciGabber » Thursday 15 March 2018 0:56

Is it possible to send openwebnet strings????

With that solution we could integrate all the automations.

Thanks :D

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Thursday 15 March 2018 7:04

Hello,

I am not sure but on post 103 are the Strings? If not where can i find this?

Thanks
Martin

Gesendet von meinem ONEPLUS A5010 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Thursday 15 March 2018 8:06

PicciGabber wrote:
Thursday 15 March 2018 0:56
Is it possible to send openwebnet strings????

With that solution we could integrate all the automations.

Thanks :D
Try to see this:
http://easydomoticz.com/forum/viewtopic.php?t=1512

PicciGabber
Posts: 4
Joined: Wednesday 14 March 2018 22:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by PicciGabber » Friday 16 March 2018 0:35

spugna85 wrote:
Thursday 15 March 2018 8:06
PicciGabber wrote:
Thursday 15 March 2018 0:56
Is it possible to send openwebnet strings????

With that solution we could integrate all the automations.

Thanks :D
Try to see this:
http://easydomoticz.com/forum/viewtopic.php?t=1512

:cry: :cry: :cry: :cry:

SyntaxError: unexpected indent
Attachments
python problema.JPG
python problema.JPG (99.23 KiB) Viewed 677 times

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Friday 16 March 2018 2:57

As indicated by the error, your problem is indentation.
You must delete the spaces at the beginning of the 3 lines:
data=s.recv(BufferSize)

I have tried the script and it works correctly.

PicciGabber
Posts: 4
Joined: Wednesday 14 March 2018 22:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by PicciGabber » Friday 16 March 2018 7:31

spugna85 wrote:
Friday 16 March 2018 2:57
As indicated by the error, your problem is indentation.
You must delete the spaces at the beginning of the 3 lines:
data=s.recv(BufferSize)

I have tried the script and it works correctly.
:(


Image

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Saturday 17 March 2018 11:41

I do not know how to help you, I tried the script on Windows with pyton 3.6.
it seems like the send function does not want a string parameter. maybe it depends on the version of pyton used? I do not know..

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Thursday 19 April 2018 7:13

Hello together,

How is the Status regarding bticino audio Implementation?

Thanks

Regards
Martin

Gesendet von meinem ONEPLUS A5010 mit Tapatalk


fmal
Posts: 20
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Problem with temperature setpoint

Post by fmal » Thursday 12 July 2018 21:08

I have two LN4691 (no central, they are setted as residential).
From domoticz I can read the temperatures, and now I discovered also two new devices, called thermostat setpoint. I tried to use them, I can see the actual temp, but if I change the setpoint, it does not apply to LN4691. Is it a bug or I have to do something more?

fmal
Posts: 20
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Re: OpenWebNet developing..?

Post by fmal » Saturday 14 July 2018 9:53

In relation to previous question: is there a simple way to "monitor" the BUS? I mean, I'm able to write programs so I would like to have a way to read the bus and to write commands to it. I have tried several apps or programs, but no one gives the function to read/write the bus. Maybe I have lost it? Also the domoticz's log does not give me the complete bus traffic, because it does not read things coming from MHS1.
Any suggestion?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests